Call booking glitch

Valued Contributor II

I had an 8 min phone call with an existing client. I clicked "book job" once I had typed in all of the information. I received a blue spinning circle in the top right hand of the screen for a few moments. The "book job" button was greyed out and I could not select it again. It was leaving me on this page and not proceeding to the next page to show the job was booked. I looked in a different tab and it had not populated this job on the dispatch board so it was as though it had not booked it. I refreshed the page and it lost everything - the call bubble, the job summary I had typed, etc. I double checked and it still showed the job hadn't been booked. I re-entered everything. It was for a double maintenance however, this second time booking it would not allow me to select the recurring services. (I thought maybe it somehow remembered me checking them off before when I tried booking it previously?). Fast forward and a few minutes later I notice that it booked this job 2x. Both jobs populated on the dispatch board and on the customer's profile. Both jobs show the recurring service events too which is odd. I canceled the one and fixed things now. But I have never had this happen. I tried to take a screen recording however, I accidentally recorded the wrong screen. (Fail - I haven't had caffeine yet today). Has anyone else experienced this before? I am hoping it is a one time occurence so didn't want to reach out to support. But I thought I would check in here to see if anyone else is having this happen. Thanks!

Note: I didn't have many tabs open. We have recently updated to faster internet. I am the only one in the office today so not much wifi is being used. I recently updated my browser as well as the software on my Macbook so it shows no needed updates.


Khiana Klatt
CSR ServicePlus Heating and Cooling

ServiceTitan Certified Provider
ServiceTitan Certified Provider

Hi @KhianaKlatt and thanks so much for bringing this to our attention!

It is absolutely not intended behavior so I'm going to check this with the product team to see if there is a known issue or maybe that was just a temporary glitch. 

I'll keep you updated in the thread and, in the meantime, let me know if you notice the issue again. 🙂