Performance Pay not available to until all invoices posted error

New Contributor II

Does anyone get errors on invoices preventing configurable payroll from running?

When looking at the job costing, it will say Performance Pay is not available until all invoices are posted.  I review and find that all invoices and payments in a project are posted and exported.  I've asked support and they don't understand the question, is there any way to fix this error? I have to make manual pay adjustments 6 times a week to solve this.

I've tried updating payroll for employees in the payroll manager, as well as updating the payroll report, and can't get past this error.




New Contributor III

Hi @cbarker, when it comes to troubleshooting invoices where Configurable Payroll is calculating performance pay, there are a few things to check.  Since you've updated payroll for employees on the Payroll Approval/Payroll Dashboard, that helps pinpoint what else you can check:

  1. Make sure the Pay Type for the technician is set to Both or Performance (we recommend this to be Both by default, especially if the tech also receives any type of hourly pay).  If Timesheets is selected, this will block any type of performance pay to calculate.  You can check this and update this in bulk by going to Settings > People > Payroll > Employee Payroll Settings
  2. The best thing to do in troubleshooting after checking the Pay Type field is to go to the actual payroll profile in Configurable Payroll, and use the Test Profile feature.  If the performance pay is not calculating when using the testing feature, then the rule might not be built correctly, and needs to be adjusted. 
  3. If the pay rules in the payroll profile have Job Filters applied, make sure the invoice meets the criteria set in the Job Filters
  4. Make sure the technicians are assigned to the payroll profiles 
  5. Navigate to the invoice, and click Update Invoice Details.  Is there a Payroll Date field?  If so, is there a date entered?  For any pay rules set to pay on the Payroll Date, it uses the date in this field.  If this field does not show, no worries.  You will look at the Invoice Date field instead.  While you're still in this section, scroll down and see if the "Exclude this invoice from bonus and commission calculations" box is selected. This is deselected by default.

If the steps above don't resolve the issue, just let me know. Thanks!

ServiceTitan Certified Provider
ServiceTitan Certified Provider

Sounds like you're doing all the right things in this situation, @cbarker, could potentially be a bug especially since you verified that all invoices are in fact posted. Are you using the master pay file to confirm which invoices are included in the issue?

Sheena @ NiFT